PPA en Debian

20 01 2012

Es innegable hoy en día la importancia de Launchpad y su PPA (Personal Package Archives), que pone a disposición de todos los usuarios de Ubuntu, gran cantidad de Software. Una manera de estar siempre a la última, en actualizaciones y versiones de programas.

Al estar Ubuntu basado en Debian, abre a este último la posibilidad de poder utilizarlas también, si bien se ve limitado principalmente por el tema de dependencias de paquetes y por la antigüedad de los mismos, teniendo más posibilidades de éxito Debian Wheezy, en su estado de testing por disponer de versiones más recientes que Squeeze,

Para Debian Wheezy y distros basada en esta, se encuentra ya disponible el paquete python-software-properties, que hace posible a través de los comandos add-apt-repository o apt-add-repositoy, el poder añadir estas PPA. Lamentablemente la versión actualmente disponible para Wheezy, no está exenta de bugs. Entre los que se encuentran principalmente:

#632754 python-software-properties: Exception when add-apt-repository PPA
#611925 sources are not recognized
#838507 apt-add-repository –remove doesn’t remove deb-src entry

Con el fin de no demorar más para los usuarios de Debian la utilización de dicha herramienta, se ha realizando un pequeño patch dando solución a los anteriores bugs, este paquete ya se encuentra disponible para su uso, desde la PPA Debian de Is Open is Free.

Instalación para Wheezy y Mint LMDE

Antes de la instalación del nuevo paquete, deberemos añadir la PPA, como hasta ahora lo estamos haciendo en Debian, es decir:

$ sudo nano /etc/apt/sources.list

Tras abrirse el editor insertamos los repositorios, al final del archivo, y damos a guardar:

deb http://ppa.launchpad.net/yunnxx/debian/ubuntu natty main
deb-src http://ppa.launchpad.net/yunnxx/debian/ubuntu natty main

Deberemos de insertar la key de dicho repositorio:

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F4784584

Tras esto actualizamos e instalamos:

$ sudo apt-get update
$ sudo apt-get install python-software-properties-patch

Si no estuviera todavía instalado el paquete python-software-properties, también será incluido en el proceso.

Recomendaciones de uso para el comando add-apt-repository

Para añadir una PPA, la forma normal de uso sería la siguiente:

$ sudo add-apt-repository ppa:razor-qt/ppa

Esto generaría un fichero con tal repositorio en /etc/apt/sources.list.d, si lo abrimos observamos que siempre pondrá por defecto el nombre de la distro en la que estamos, por ejemplo Wheezy, evidentemente esto no es correcto, ya que el nombre correcto que admite para estos repositorios en concreto, como observamos en la imagen, sería para las versiones de Ubuntu Lucid, Maverick, Natty y Oneiric. Deberemos por tanto seleccionar la que en un principio sea más compatible con nuestro Debian. En este caso y para Wheezy sería Oneiric.

Debido a esto deberíamos abrir el editor y realizar la corrección a mano. Para evitar esto se ha añadido una mejora en el comando add-apt-repositoy con la posibilitad de poder añadir el nombre de la distro. Quedando la sintaxis del comando de la siguiente manera:

$ sudo add-apt-repository ppa:razor-qt/ppa/oneiric

Para el borrado, quedaría:

$ sudo add-apt-repository -r ppa:razor-qt/ppa/oneiric

Recordar que el nombre de la distro se deberá de escribir con todas las letras en minúscula.

Pues ya que estamos y sin haber realizado el borrado PPA, procedemos con instalación de razorqt, que seria:

$ sudo apt-get update
$ sudo apt-get install razorqt

Instalación para Debian Squeeze

Para Squeeze no disponemos del python-software-properties en sus repositorios, pero es totalmente viable el utilizado por Natty. Procedemos por tanto con su instalación:

$ cd
$ mkdir tmp
$ cd tmp
$ wget http://launchpadlibrarian.net/70339502/python-software-properties_0.80.9_all.deb
$ sudo dpkg -i python-software-properties_0.80.9_all.deb
$ cd ..
$ rm -r tmp

A continuación procedemos a aplicar el patch, como anteriormente se ha indicado para la instalación de Wheezy y Mint LMDE. Lamentablemente no es posible la instalación de razorqt por temas de dependencias.

Ya por último y es importante recordad, que este path es solamente aplicable hasta esta versión 0.80.9 de Natty, ya que para versiones posteriores en Oneiric, no es necesario, ya que estos bugs fueron solucionados. Tambien mencionar que este patch se ha probado con exito en Debian Squeeze, Dreamlinux 5 (Wheezy) y Mint LMDE.

Que lo disfrutes🙂


Acciones

Information




A %d blogueros les gusta esto: